Tools → Schema Manager

About the Schema Manager

The Schema Manager allows a tenant user with the necessary access rights to search for, create, and manage the following:

  • Physical schemas
  • Internal, external, and filter expression session variables
  • Global variables
Note

The Global Variables tab is available in the Schema Manager starting with release 4.9.

Schema Manager access rights

A user that belongs to a group with the Schema Manager or the SuperRole role can access the Schema Manager. To access the Schema Manager for a given tenant, in the Navigation bar, select Schema.

Note

In addition to global variables that are available to all tenant users, a user that belongs to a group with the Analyze User or Individual Analyzer role can access objects created in the Schema Manager (physical schemas and session variables) and shared with this user when developing or editing dashboards in the Analyzer.

Schema Manager anatomy

The Schema Manager consists of the following:

  • Action bar
  • Context bar
  • Search bar
  • List view

Action bar

The Action bar shows the page title.

+ New in the Action bar opens the Add New menu. The Add New menu options are:

  • Create Schema
  • Schema Wizard
  • Import Schema
  • Session Variable
    • External Variable
    • Internal Variable
    • Filter Expression
  • Global Variable

Context bar

The Context bar consists of three tabs: Schema, Session Variables, and Global Variable. Tab selection determines the search context as well as the List view results.

Note

When the Context bar tab selection is Schema, the size of the data on the disk is displayed, and the Refresh (circle with arrow icon) is available to refresh the list view and recalculate the data size.

The Search bar contains a search text box. Search for any part of a given search term. When the Context bar tab selection is Schema, the search returns a result list of zero or more physical schemas. When the tab selection is Session Variables, the search returns a result list of zero or more session variables, whether internal, external, or filter expression session variables. When the tab selection is Global Variables, the search returns a result list of zero or more global variables.

The Search bar shows:

  • The number of items in the result list
  • The number of selected items in the result list with the option (x) to deselect the items
  • Other options that may vary depending upon the Context bar tab selection, the number of selected items, and the user access rights:
    • When the Context bar tab selection is Schema, More Options (⋮ vertical ellipsis) appear. The available options are:
      • Export: use to export the selected physical schemas to an Incorta package
      • Delete: use to delete all selected physical schemas
      • Create Email Notification: use to create an email notification for the selected physical schemas
    • When the Context bar tab selection is Session Variables and you select multiple items that you can edit (i.e. items that you own or have Edit access rights to), Delete (trash can icon) is available. Use it to delete all selected items.
    • When the Context bar tab selection is Session Variables, and you select only one item that you can edit (i.e. an item that you own or have Edit access rights to), the following options appear:
      • Edit (pen icon): use to edit the selected item
      • Share (people icon): use to share the selected item
      • Delete (trash can): use to delete the selected item
    • When the Context bar tab selection is Global Variables, Delete (trash can icon) is available. Use it to delete all selected items
Note

You can delete only items that you have Edit access rights to.

List view

The List view shows all results for a given search term and search context. By default, the list view only shows items where the given user has at least view access rights to the items.

Note

Only the Super User tenant administrator can view all items, regardless of the access rights to the objects.

The List view shows a specific number of items at a time: 40 items for the Schemas tab and 20 for the Session Variables and Global Variables tabs. For lists with more than this number of items, the List view contains page controls. The page controls allow the user to navigate pages forwards or backwards as well as to the first page or to the last page of items.

Schemas list view

By default, the Schema items appear in alphabetical, ascending order. To sort the items by the column values in either ascending or descending order, select a specific column header. For any schema row, select any column other than the Status and Last Load links, to open the item in the Schema Designer.

For Schemas, the List view shows the following properties:

PropertyControlDescription
Select Allcheck boxHeader control to add or remove all list view page items to a group for deletion, export, or email notification creation
Select Itemcheck boxSelect to add or remove an individual item to a group of zero or more items for deletion
NametextThe name of the physical schema
Load StatuslinkThe status of the last or current load job. Hover over it to display the time spent for each phase in the load job. Select it to go to the job details.
Last Successful LoadtimestampThe date and time of the last successful load job for the physical schema, if any
Last LoadlinkA letter that represents the type of the last or current load job and its start date and time, if any, regardless of the job status. The letter is one of the following:
    •  F for Full load
    •  I for Incremental load
    •  S for Staging
Select the timestamp link, if any, to go to the job details.
Next LoadtimestampThe type and the date and time for the next scheduled load job, if any
Model StatuslinkThe status of the last or current schema update job (model update job). Hover over it to display the time spent for each phase in the update job. Select it to go to the Model Update Viewer.
For newly added physical schemas (whether created or imported without overwriting existing ones), no model status is available.
If one or more of the physical schema objects have changes that require loading data, there will be a triangle with an exclamation mark next to the status till the required load occurs, whether manually or through a scheduled job.
If the current update job is still in queue because one or more load or update jobs are blocking it, the Model Status (In Queue) will be a link that opens a pop-up that shows a list of these blocking jobs.
Data SizetextThe size of the physical schema data that is loaded into the engine memory
OwnertextThe display name of the user creator
Modified BytextThe display name of the user that last modified the physical schema
More Options → Edit Descriptionmenu linkOpens the Edit Description dialog
More Options → Performance Optimizationmenu linkOpens the Optimize Table Performance dialog
More Options → Change Load Ordermenu linkOpens the Choose Load Order dialog
More Options → Schedulemenu linkOpens the Add Schema Load dialog
More Options → Sharemenu linkOpens the Share dialog
More Options → Exportmenu linkOpens the Export Schema(s) dialog
More Options → Create Email Notificationmenu linkOpens the Create Email Notification dialog
More Options → Deletemenu linkOpens the confirmation dialog for the physical schema deletion
Important

For physical schemas with dependencies, a physical schema load or update job can block the load and update jobs of dependent physical schemas. Blocked update jobs stay in the In Queue state until all blocking jobs are completed while the blocked load jobs stay in the Load state. You can view a list of jobs that block update jobs. For more details, see View blocking jobs.

Session Variables list view

By default, the Session Variable items appear in alphabetical, ascending order. For Session Variables, the list view shows the following properties:

PropertyControlDescription
NametextThe name of the session variable
DescriptiontextThe description of the session variable, if any
TypetextThe session variable type:
    •  External
    •  Internal
    •  Filter Expression
PermissiontextShows the access rights:
    •  View
    •  Share
    •  Edit
OwnertextThe display name of the user creator
Edit (pen icon)icon linkOpens the item details dialog (depending upon the session variable type) for editing:
    •  External Variable dialog
    •  Internal Variable dialog
    •  Filter Expression dialog
View (eye icon)icon linkOpens the item details dialog for viewing only. This button is available if you have view or share access rights to the session variable.
Share (people icon)icon linkOpens the Share dialog. This button is available if you have view or share access rights to the session variable.
Delete (trash can icon)icon linkOpens the confirmation dialog for the session variable deletion

Global Variables list view

By default, the Global Variable items appear in alphabetical, ascending order. For Global Variables, the list view shows the following properties:

PropertyControlDescription
NametextThe name of the global variable
DescriptiontextThe description of the global variable, if any
OwnertextThe display name of the user creator
Edit (pen icon)icon linkOpens the Edit Global Variable dialog
Delete (trash can)icon linkOpens the confirmation dialog for the global variable deletion

Schema Manager actions for physical schemas

With the Schema Manager, you can perform the following actions for physical schemas:

Schema Manager access rights matrix

As a user that belongs to a group with the Schema Manager or the SuperRole role, you can access the Schema Manager. You can import physical schemas and create them, whether with the Schema Wizard or the Schema Designer. However, to be able to view, search for, or manage items on this page, you need to have the suitable access rights to them.

The following table shows the required access rights for each action.

Action/Access RightsOwner/EditShareView
Schema → View on list
Schema → Search for or filter
Schema → View details
Schema → View Description
Schema → Add/Edit Description
Schema → Edit details
Schema → Export
Schema → Create email notification
Schema → Optimize table performanceView onlyView only
Schema → Manage load orderView onlyView only
Schema → Schedule load
Schema → ShareView only
Schema → Delete

Create a physical schema with the Schema Wizard

Important

Validation Rules for a physical schema name

A physical schema name…

  • Must be unique
  • Must be between 1 and 250 characters in length
  • Must begin with an alpha character, lower or upper case
  • After the first alpha character, can contain zero or more alphanumeric characters in lower, upper, or mixed case
  • After the first alpha character, can contain zero or more underscore (_) or Dollar sign ($) characters
  • Besides underscore (_) and Dollar sign ($), cannot contain special characters, symbols, or spaces

Here are the steps to create a physical schema with the Schema Wizard:

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewSchema Wizard.
  • In (1) Choose a Source, specify the following:
    • In Enter a name, enter the physical schema name.
    • In Select a Datasource, select the external data source.
    • Optionally, create a description.
  • In the Schema Wizard footer, select Next.
  • In (2) Manage Tables, in the Data panel, select the name of the Data Source, and then select the tables, files, or worksheets you want or select the Select All check box to select all tables, files, or worksheets depending upon the data source you selected.
  • In the Schema Wizard footer, select Next.
  • In (3) Finalize, in the Schema Wizard footer, select Create Schema.

Create a physical schema with the Schema Designer

Before creating a physical schema with the Schema Designer, review References → Connectors → for specific table property definitions.

Here are the steps to create a physical schema using the Schema Designer:

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewCreate Schema.
  • In Name, specify the physical schema name, and select Save.
  • In Start adding tables to your physical schema, select one of the following:
    • Schema Wizard: to use the Schema Wizard to select the tables, files, or worksheets you want to add
    • Incorta Analyzer: to use the Analyzer to create a table or aggregated table insight as a physical schema Incorta Analyzer table
    • Incorta SQL: to use Incorta SQL Engine to create an Incorta SQL table by querying objects in the same or other physical schemas. The Incorta SQL table is still a lab feature that you need to enable before use.
    • SQL Table: to create a SQL table from different data source types, such as MySQL, Oracle, IBM DB2, Cassandra (Simba), NetSuite Suite Analytics, Presto, SAP Hana, and BigQuery
    • File System: to create a table from a local data file
    • Cassandra: to create a table from an Apache Cassandra data source
    • Cisco Meraki: to create a table from a Cisco Meraki data source
    • Data Lake: to create a table from a Data Lake data source
    • DynamoDB: to create a table from an AWS DynamoDB data source
    • Essbase: to create a table from an Oracle Essbase data source
    • Freshservice: to create a table from a Freshservice data source
    • Google Sheets: to create a table from a Google Sheets data source
    • Kafka: to create a table from an Apache Kafka data source
    • NetSuite: to create a table from a NetSuite Web Service data source
    • OneLogin: to create a table from a OneLogin data source
    • Oracle Cloud Applications: to create a table from an Oracle Cloud Application data source
    • SalesForce: to create a table from a Salesforce data source
    • ServiceNow: to create a table from a ServiceNow data source
    • SharePoint: to create a table from a SharePoint data source
    • Splunk: to create a table from a Splunk data source
    • Zuora: to create a table from a Zuora data source
    • Materialized: to create a Materialized View
    • Alias: to create an alias that references a selected physical schema object, in the same physical schema or other physical schemas
  • In the Data Source dialog, specify the properties for the given object.
  • Select Add.
  • In the Table Editor, in the Table Summary section, enter the physical schema object name.
  • To save your changes, in the Action bar, select Done.

Import a physical schema

You can import one or more physical schemas that exist in the same .zip file. When you import a physical schema, if there is no physical schema that shares the same name with the imported one, a new physical schema is created from this imported one with no version. If you try to import a physical schema that shares the name with an existing one, the import fails. However, you can overwrite this existing physical schema. When you overwrite a physical schema that has saved versions (whether named or not), these versions are not deleted, and a new saved version is added as the current version.

Note

You cannot import a physical schema with the Overwrite existing schema option enabled if another user is editing it in the draft mode nor during a schema update job.

Here are the steps to import a physical schema:

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewImport Schema.
  • In the Import Schema dialog, optionally select the Overwrite existing schema check box to overwrite any existing physical schema that shares the same name with the imported one, if any.
  • Do one of the following:
    • Drag the .zip file that contains the physical schema(s) that you want to import to the Import Schema dialog.
    • Select Click or drag a file here to upload to select the .zip file, and then select Open.
  • Wait until the physical schema(s) and scheduled load job(s), if any, are imported.
  • In the Import Results dialog, review the status of the import operation.
  • Select Close.

The following are the details in the Import Results dialog:

PropertyDescription
NameThe name of the physical schema or scheduled load job
TypeThe type of the imported item: Schema or Scheduler
StatusThe status of the import operation. It can be one of the following:
    •  Created
    •  Overwritten
    •  Failed
If the import operation fails, the reason is displayed. If the physical schema import operation fails, related scheduled load jobs are not imported even if the same physical schema already exists.

View a list of physical schemas

  • In the Navigation bar, select Schema.
  • On the Schemas tab, review the list view of physical schemas.

Search for a physical schema

  • In the Navigation bar, select Schema.
  • On the Schemas tab, in the Search bar, enter a search term.
  • Review the list view of physical schemas.

To reset the search, in the Search bar, in the search box, select the remove button (x).

Filter physical schemas by the load status

  • In the Navigation bar, select Schema.
  • On the Schemas tab, in the list view header row, select the filter icon next to Load Status.
  • Select one or more load statuses to filter the physical schemas list view. The load status options are:
    • Succeeded
    • Finished With Errors
    • Failed
    • Interrupted
    • Running
    • In Queue
  • Select OK.

Reset the load status filter

  • In the Navigation bar, select Schema.
  • On the Schemas tab, in the list view header row, select the filter icon next to Load Status.
  • Select Reset.

Filter physical schemas by the model update status

  • In the Navigation bar, select Schema.
  • On the Schemas tab, in the list view header row, select the filter icon next to Model Status.
  • Select one or more model update statuses to filter the physical schemas list view. The model update status options are:
    • Succeeded
    • Finished With Errors
    • Failed
    • Interrupted
    • Running
    • In Queue
  • Select OK.

Reset the model update status filter

  • In the Navigation bar, select Schema.
  • On the Schemas tab, in the list view header row, select the filter icon next to Model Status.
  • Select Reset.

Edit a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema that you own or have edit access rights to, select any part of the row except the Status and Last Load links.
  • In the Schema Designer, you can do the following:
    • view a list of the physical schema objects and joins
    • add, edit, or remove physical schema objects
    • add, edit, or remove joins between the physical schema objects
    • load data for the physical schema
    • load data for a selected physical schema object
    • view or manage load jobs
    • open the Table Editor for a selected physical schema object
    • switch to the Diagram view
    • open the Join Editor for a select join
    • explore physical schema data
    • add or edit a physical schema description
    • optimize performance for the physical schema objects
    • change the load order of the physical schema objects
    • schedule the load of a physical schema
    • share a physical schema
    • create physical schema load email notifications

View physical schema details

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema, select any part of the row except the Status and Last Load links.
  • In the Schema Designer, you can do the following:
    • view load jobs
    • view physical schema objects and joins
    • view physical schema object details, such as the columns, formula columns, and load filters
    • explore physical schema data
    • view the physical schema diagram
    • view or edit the share options for the physical schema depending upon the access rights
    • view the physical schema description, objects load order, and performance optimization settings for the physical schema objects
    • create a physical schema load email notification

For more information, refer to Tools → Schema Designer

View the load job details for a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema, select the Load Status or Last Load link.
  • In the Load Job Viewer, review the details of the load jobs for the physical schema.

View the physical schema update jobs

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema, select the Model Status link.
  • In the Model Update Viewer, review the details of the physical schema update jobs.

View blocking jobs

When an update job or a load job is in the commit phase or the load and post-load phase, respectively, it blocks the update and load jobs on dependent physical schemas. A dependent physical schema is one that has a cross join relationship with another physical schema. The blocked update jobs stay in the In Queue state till all blocking jobs are completed while the load jobs stay in the Load state. Starting with the 5.1.2 release, as a schema manager user, you can view a list of jobs that block update jobs in the Schema Manager and the Model Update Viewer. This list shows the blocking physical schema, the type of the blocking job, load or update, and the current status of each blocking job. You can also access the details of the blocking job in the Load Job Viewer or the Model Update Viewer according to the type of the blocking job.

Here are the steps to view the list of blocking jobs of an update job in the Schema Manager:

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema that has a blocked update job, in Model Status, select the In Queue link. A pop-up dialog appears with a list of the blocking jobs.
  • To view the details of a blocking job, in the pop-up dialog, select See Job Details.

Add or edit a physical schema description

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Edit Description.
  • In the Edit Description dialog, enter or update the physical schema description. You can enter up to 500 alphanumeric characters, including spaces and special characters.
  • Select Save.

Optimize performance for physical schema objects

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Performance Optimization.
  • In the Optimize Table Performance dialog, in the objects list, for each object you want to optimize the performance, select the check box, and for each object that you do not want to optimize the performance, clear the check box.
  • Select Save.
Warning

You must enable performance optimization for Incorta Analyzer tables and Incorta SQL tables to avoid load failure.

Note

For objects that you enable for performance optimization, the Loader Service will load their files from Shared Storage (Staging) into the Engine memory. For unselected objects, the Loader Service will load data only into Shared Storage, which can slow the speed of creating insights; however, this will reduce the load time.

Change the load order of physical schema objects

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Change Load Order.
  • In the Choose Load Order dialog, you can do the following to manage the table groups before changing their load order:
    • For each table or Materialized View that you want to add to a new load group, select the check box, and then select Add to New Group.
    • For each table or Materialized View that you want to add to an existing load group, select the check box, and then select Add to Existing Group.
    • To reset table grouping and order, select Revert to Default.
  • To set the order of a table group, select the up arrow (to the right of the group name) to move the group upwards, or select the down arrow (to the right of the group name) to move the group downwards. Repeat this action until you order the table groups as required.
  • Select Save.

Schedule the load of a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Schedule.
  • In the Add Schema Load dialog, in Schema Load Name, enter the name of the scheduled load job. You can enter up to 255 alphanumeric characters, including spaces, special characters, and emojis.
  • In Description, optionally enter a description for the scheduled load job. You can enter up to 255 alphanumeric characters, including spaces, special characters, and emojis.
  • The Schema box shows the selected physical schema.
  • In Load Type, select the load type. The available options are:
    • Full
    • Incremental (default)
    • Staging
  • In the Every section, specify the frequency and recurrences of this job.
    • Enter a number.
    • Select the time measure unit: minutes, hours, days, weeks, or months.
    • Select the No recurrence check box to run this job only once.
  • In the Starting At/At section, specify the time to run this job. Select the time and time zone.
  • Specify the validity period of the scheduled load job:
    • If the job is recurring, in the From section, do one of the following:
      • Select the start date and keep the Does not end check box selected to run it forever.
      • Select the start date, clear the Does not end check box, and select the end date to run the job during this period.
    • If the job is not recurring, in the On section, select the date to run this job.
  • Select Add.
Note

Scheduled load jobs appear in the Scheduler, under Schema Loads. A user with the appropriate access rights to the Scheduler can manage these jobs, in addition to creating new jobs.

Share a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Share.
  • In the Share dialog, you can do the following:
    • remove an existing user or group
    • modify the existing access rights for a user or group
    • add a new user or group with the required access rights

Export a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Export.
  • In the Export Schema(s) dialog, optionally select the Include scheduled jobs check box to include scheduled load jobs related to the selected physical schema in the export operation.
  • Select Export. The exported physical schema .zip file is downloaded to the Downloads folder.
Note

When you export a physical schema, you export the current saved version only. No drafts or old saved versions are exported. To export a previous saved version, use the Schema Designer, for more details, refer to Export a saved version.

Export one or more physical schemas

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for each physical schema that you want to export, select the check box.
  • In the Search bar, next to Selected, select More Options (⋮ vertical ellipsis).
  • Select Export.
  • In the Export Schema(s) dialog, optionally select the Include scheduled jobs check box to include scheduled load jobs related to the selected physical schema(s) in the export operation.
  • Select Export. The exported physical schema(s) .zip file is downloaded to the Downloads folder.

Create physical schema load email notifications

Important

Notifications require a tenant email configuration for an outgoing email server using SMTP or EWS in the Cluster Management Console (CMC).

Created notifications appear on the Scheduler, under Schema Notifications. A user with the appropriate access rights to the Scheduler can manage these notifications, in addition to creating new ones.

Create an email notification for a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Create Email Notification.
  • In the Create Email Notification dialog, enter the details of the email notification. For more information, see Email notification details.

Create an email notification for one or more physical schemas

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for each physical schema that you want to include in the email notification, select the check box.
  • In the Search bar, next to Selected, select More Options (⋮ vertical ellipsis).
  • Select Create Email Notification.
  • In the Create Email Notification dialog, enter the details of the email notification. For more information, see Email notification details.

Email notification details

When you create an email notification for a given physical schema or multiple physical schemas, in the Create Email Notification dialog, enter the following:

  • In Notification Name, enter the name of the new email notification. The length of the notification name must be between 1 and 255 alphanumeric characters, including spaces and special characters.
  • In the Notify On section, select the Success and/or Failure check boxes to specify the load operation status that triggers sending the notification email.
  • The Select Schema(s) section, by default, shows the physical schema(s) selected. You can do the following:
    • In Search any schema name, enter a search term to search for specific physical schemas, and then in the search result list, select the physical schema(s) you want.
    • Select the Select All check box to include in the email notification all physical schemas you have access to or all physical schema(s) in the search result list.
    • In the physical schemas list or search result list, for each physical schema that you want to include in the email notification, select the check box.
  • In the Recipients section, to add a recipient, in Search Names, Emails, and Groups, do one of the following:
    • To add a user or group of users, enter a search term to search for users or groups in the tenant, and then select the user or group from the search result list.
    • To add an external recipient, enter the email address, and then select the external recipient.
  • In the Recipients list, for each recipient, select V (down arrow) to the right of the recipient name or email, and then select where the given recipient should go to: the To list, Cc list, or Bcc list.
  • Optionally, in Body, enter the email body text. The body text you enter appears in the notification email before an auto-generated text. You can enter up to 4000 alphanumeric characters, including spaces and special characters.
  • Select Done.
Note

When you create an email notification that contains multiple physical schemas, the recipient(s) receives a separate email for each physical schema. Recipients on the Bcc list do not appear on the received email, while those on the To and Cc lists do appear.

The notification email contains the following:

  • the email body text you entered, if any
  • the notification name
  • the display name of the notification user creator
  • the physical schema name
  • the physical schema load status
  • the load date and time
  • the load duration
  • a link to the Load Job Viewer that contains the physical schema load job summary and details

Delete a physical schema

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for a given physical schema row, select More Options (⋮ vertical ellipsis).
  • Select Delete.
  • In the dialog, select Delete.
Note

You cannot delete a physical schema if another user is editing it in the draft mode.

Delete one or more physical schemas

  • In the Navigation bar, select Schema.
  • In the list view of physical schemas, for each physical schema that you want to delete, select the check box.
  • In the Search bar, next to Selected, select More Options (⋮ vertical ellipsis).
  • Select Delete.
  • In the dialog, select Delete.

Schema Manager actions for session variables

Using the Schema Manager, you can perform the following actions for session variables:

Important

Validation Rules for a session variable name

A session variable name…

  • Must be unique
  • Must be between 1 and 250 characters in length
  • Must begin with an alpha character, lower or upper case
  • After the first alpha character, can contain zero or more alphanumeric characters in lower, upper, or mixed case
  • After the first alpha character, can contain zero or more underscore (_) characters
  • Besides underscore (_), cannot contain special characters, symbols, or spaces

Create an external session variable

An external session variable stores a scalar value or an array of values from the result of a query to an external data source. For more information, please refer to Concepts → External Session Variable

Here are the steps to create an external session variable:

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewSession VariableExternal Variable.
  • In the External Variable dialog, in Name, enter the name of the external session variable.
  • In Description, optionally enter a description.
  • In Data Source, select the data source to query its data.
  • In Query, construct the query to request and retrieve data from the selected data source. The query result is the external session variable value(s).
  • Optionally, select Test to test the query expression for the logged-in user and view the query value(s), if any.
  • Optionally, select Test As, and then search for and/or select a user to test the query expression for the selected user and view the query value(s), if any.
  • Select Add.

Create an internal session variable

An internal session variable stores a scalar value or an array of values from the result of an internal query expression. Using the Formula Builder, you can define an internal query expression. An internal query expression queries a physical schema object or runtime business view. In this regard, the adjective “internal” references physical schemas and business schemas within a given tenant. For more information, please refer to Concepts → Internal Session Variable

Here are the steps to create an internal session variable:

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewSession VariableInternal Variable.
  • In the Internal Variable dialog, in Name, enter the name of the internal session variable.
  • In Description, optionally enter a description.
  • Select Query to invoke the Formula Builder to construct the internal query expression to request and retrieve data from a physical schema object or runtime business schema view. The query result is the internal session variable value(s).
  • Optionally, select Test to test the internal query expression for the logged-in user and view the query value(s), if any.
  • Optionally, select Test As, and then search for and/or select a user to test the internal query expression for the selected user and view the query value(s), if any.
  • Select Add.

Create a filter expression session variable

A filter expression session variable is a filter expression created in the Schema Manager. Incorta introduces filter expression session variables to allow you to create a filter expression just once and reference it in different contexts. For more information, please refer to Concepts → Filter Expression Session Variable.

Here are the steps to create a filter expression session variable:

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewSession VariableFilter Expression.
  • In the Filter Expression dialog, in Name, enter the name of the filter expression session variable.
  • In Description, optionally enter a description.
  • Select Filter to invoke the Formula Builder to construct the filter expression.
  • Select Add.
Note

Testing the filter expression session variable will only show the filter expression, as the filter expression is only a boolean expression that returns true or false when evaluated in its context.

View a list of session variables

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • On the Session Variables tab, review the list view of session variables.

Search for a session variable

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • On the Session Variables tab, in the Search bar, enter a search term.
  • Review the list view of session variables.

To reset the search, in the Search bar, in the search box, select the remove button (x)

Edit a session variable

You can edit session variables that you own or have edit access rights to.

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • In the list view of session variables, for a given session variable that you can edit, do one of the following:
    • select any part of the row
    • select Edit (pen icon)
    • select the check box, and then in the Search bar, next to Selected, select Edit (pen icon)
  • In the dialog, you can do the following:
    • add or edit the session variable description
    • edit the query expression of an internal or external session variable or the filter expression of a filter expression session variable, and save updates
    • test the session variable as the logged-in user
    • test the session variable as another user
  • To save updates, select Save.

View session variable details

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • In the list view of session variables, for a given session variable, select View (eye icon) or select any part of the row.
  • In the dialog, review the details of the session variable.

Share a session variable

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • In the list view of session variables, for a given session variable, select Share (people icon).
  • In the Share dialog, you can do the following:
    • remove an existing user or group
    • modify the existing access rights for a user or group
    • add a new user or group with the access rights

Delete a session variable

You can delete items that you own or have Edit access rights to.

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • In the list view of session variables, for a given variable row, select Delete (trash can icon).
  • In the dialog, select Delete.

Delete one or more session variables

You can delete items that you own or have Edit access rights to.

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Session Variables tab.
  • In the list view of session variables, for each variable that you want to delete, select the check box. You have to select only items that you own or have Edit access rights to.
  • In the Search bar, next to Selected, select the delete icon (trash can).
  • In the dialog, select Delete.

Schema Manager actions for global variables

A global variable is a static variable. Unlike other objects in Incorta, a global variable is available to all tenant users. A user that belongs to a group with the Schema Manager or the SuperRole role can create and manage all global variables in the tenant.

It is not possible for the value of a global variable to reference another variable, such as an external session variable, internal session variable, or another global variable for dynamic evaluation. It is possible; however, to edit the value of an existing global variable and to insert the instant value of a date system variable of the type date or timestamp (date system variable of the type integer is not supported) for the value of a global variable of the type date or timestamp, respectively.

For more information, please refer to Concepts → Global Variable

Using the Schema Manager, you can perform the following actions for global variables:

Important

Validation Rules for a global variable name

A global variable name…

  • Must be unique
  • Must be between 1 and 250 characters in length
  • Must begin with an alpha character, lower or upper case
  • After the first alpha character, can contain zero or more alphanumeric characters in lower, upper, or mixed case
  • After the first alpha character, can contain zero or more underscore (_) characters
  • Besides underscore (_), cannot contain special characters, symbols, or spaces

Create a global variable

  • In the Navigation bar, select Schema.
  • In the Action bar, select + NewGlobal Variable.
  • In the Global Variable dialog, in Name, enter the name of the global variable.
  • In Description, optionally enter a description.
  • In Type, select the type of the global variable. The type of a global variable is an Incorta data type: Available options are:
    • date
    • double
    • integer
    • long
    • string
    • timestamp
  • In Value, enter the global variable value as appropriate to the global variable type.
  • Select Create.
Note

Starting with release 5.0, for the value of date and timestamp global variables, you can insert the current value of a date system variable of the type date or timestamp, respectively. Once you insert the value, it cannot be automatically updated; however, you can manually update it.

For date global variables, you can insert the current value of the following date system variables:

  • $currentDate
  • $currentYearStart
  • $currentQuarterStart
  • $currentMonthStart
  • $currentMonthEnd
  • $currentWeekStart
  • $lastYearStart
  • $lastQuarterStart
  • $lastMonthStart
  • $lastWeekStart
  • $nextMonthStart
  • $dayAgo
  • $monthAgo
  • $quarterAgo
  • $weekAgo
  • $yearAgo

For timestamp global variables, you can insert the current value of the $currentTime date system variable.

You cannot use integer date system variables for the value of a global variable.

View a list of global variables

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Global Variables tab.
  • On the Global Variables tab, review the list view of global variables.

Search for a global variable

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Global Variables tab.
  • On the Global Variables tab, in the Search bar, enter a search term.
  • Review the list view of global variables.

To reset the search, in the Search bar, in the search box, select the remove button (x)

Edit a global variable

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Global Variables tab.
  • In the list view of global variables, for a given global variable, do one of the following:
    • select any part of the row
    • select the edit icon (pen icon)
  • In the dialog, make the necessary configuration updates.
  • Select Ok.

Delete a global variable

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Global Variables tab.
  • In the list view of global variables, for a given row, select Delete (trash can icon).
  • In the dialog, select Delete.

Delete one or more global variables

  • In the Navigation bar, select Schema.
  • In the Context bar, select the Global Variables tab.
  • In the list view of global variables, for each global variable that you want to delete, select the check box.
  • In the Search bar, next to Selected, select Delete (trash can icon).
  • In the dialog, select Delete.