You are viewing content for 5.0 | 4.9 | 4.8 | 4.7 | 4.6 | 4.5 | 4.4 | 4.3 | Previous Releases


Tools → Schema Designer

About the Schema Designer

The Schema Designer allows you to manage entity objects and joins for a physical schema. You also use the Schema Designer to initiate or schedule a load job for an entire physical schema or a given entity object in the physical schema.

Schema Designer permissions and access rights

A user that belongs to a group with the Schema Manager or the SuperRole role can access the Schema Designer for a given physical schema that the user owns or has View access rights to. A SuperUser that is a Tenant Administrator can also access the Schema Designer for a given physical schema. However, a user must own or have Edit access rights to the physical schema to use the Schema Designer to manage its entity objects, joins, and load jobs. Some functions require additional roles, such as the Explore Data function that requires a role that can manage the Catalog (Content Manager).

Access the Schema Designer

To access the Schema Designer, in the Navigation bar, select Schema, and then on the Schemas tab, select a given physical schema.

You can also access the Schema Designer for a given schema from the Load Job Viewer. In the Header bar, in the breadcrumb trail, select the name of the physical schema.

Schema Designer access rights matrix

The following table shows the required access rights to a given physical schema for each action that you can perform using the Schema Designer.

Action/Access Rights Owner/Edit Share View
Add or edit the physical schema description View only View only
Search for a physical schema object
Search for a column in physical schema objects
Optimize load performance for the physical schema objects View only View only
Change the load order for the physical schema objects View only View only
Share the physical schema View only
Explore physical schema data (Requires a role that can manage the Catalog (Content Manager)
Preview the physical schema join diagram
Sort physical schema objects list view
Perform a full load for physical schema data
Perform an incremental load for physical schema data
Load physical schema data from staging
Schedule a physical schema load job
Perform a full load for a physical schema object
Load physical schema object data from staging
Review the status of a load job
Create a physical schema load email notification
Create one or more physical schema tables using the Schema Wizard
Create a physical schema entity object
View physical schema object details
Edit a physical schema object
Delete a physical schema object
Create a join relationship
Sort joins list view
View join relationship properties
Edit a join relationship
Remove a join relationship

Schema Designer anatomy

The Schema Designer consists of the following:

  • Action bar
  • Summary/Header section
  • Tables section
  • Joins section

Action bar

The Action bar contains the following options:

Option Description Comments
Search Enter a search term to search for a physical schema entity object or a column in the physical schema, if any. Select an object or column from the search result list to open the respective object in the Table Editor.
Load Select to open the Load menu. Available options are:
  • Load now
  • Schedule
  • Available only in the case of a physical schema that has entity object(s)
    Load → Load now Select to load data for the physical schema objects. Available load strategies are:
  • Full
  • Incremental
  • Staging
  • Load now → Full Instructs the Loader Service to:
  • flush out all Direct Data Mapping files and Parquet files that exist in Shared Storage for the physical schema objects
  • extract the data from data source(s)
  • create Parquet files and Direct Data Mapping (DDM) files in Shared Storage
  • For objects that you enable for performance optimization, the Analytics Service will also load the snapshot (DDM) files from Shared Storage (Staging) into its in-memory Direct Data Mapping engine.
    Although it is a Full Load, the Loader Service will run the load in incremental mode for entity objects with incremental load enabled and full load disabled.
    Load now → Incremental Instructs the Loader Service to run the load in incremental mode for only objects with incremental load enabled. The Loader Service will not extract data for other objects. Depending upon the data source properties, the Loader Service will use an Update Query SQL statement or an Update File to determine which data to extract from the data source.
    Load now → Staging Instructs the Loader Service to not extract data from the data source for the physical schema objects while the Analytics Service will load into its in-memory Direct Data Mapping engine the related snapshot (DDM) files from Shared Storage (Staging).
    Load → Schedule Select to create a scheduled job for loading the physical schema data
    Stop Select to stop or interrupt the load activities of a running load job. The status of the load job becomes Interrupted. Available only during a running load job
    Explore Data Select to access the Analyzer to explore the physical schema data. Available only in the case of a physical schema that has entity object(s) and requires a role that can manage the Catalog, that is, the Content Manager
    Diagram Select to access the Schema Diagram Viewer to view the join paths among objects in the physical schema itself or join paths to or from other physical schemas, if any
    Settings (gear icon) Select to open the Settings menu. Available options are:
  • Edit Description
  • Performance Optimization
  • Change Load Order
  • Create Notification
  • Share
  • Settings → Edit Description Select to add or edit the physical schema description
    Settings → Performance Optimization Select to manage which physical schema objects you want to enable for performance optimization.
    For objects that you enable for performance optimization, the Analytics Service will load the snapshot (DDM) files from Shared Storage (Staging) into its in-memory Direct Data Mapping engine.
    For unselected objects, the Loader Service will load data only into Shared Storage, which can slow the speed of creating insights; however this will reduce the load time.
    Available only in the case of a physical schema that has entity object(s)
    Settings → Change Load Order Select to configure the load order of physical schema tables by one or more groups and materialized views by one or more groups Available only in the case of a physical schema that has entity object(s)
    Settings → Create Notification Select to schedule email notifications for the load jobs of the physical schema (and/or other physical schemas) Available only in the case of a physical schema that has entity object(s)
    Settings → Share Select to view or manage the physical schema share options
    + New Select to open the Add New menu. Available options are:
  • Schema Wizard
  • Table
  • Alias
  • Derived Table
  • Join
  • + New → Schema Wizard Select to add a new physical schema table using the Schema Wizard
    + New → Table Select to add a physical schema table using a specific data source or connector
    + New → Alias Select to create a new alias that references one of the existing objects in the same physical schema or another physical schema
    + New → Derived Table Select to add a new derived table, that is, one of the following:
  • Incorta Analyzer table
  • Incorta SQL table
  • Materialized View
  • The term “Derived Table” was introduced starting with release 5.0.
    Derived Table → Incorta Analyzer Select to use the Analyzer to create a new Incorta Analyzer table Prior to release 5.0, you can access this option from + NewTableIncorta
    Derived Table → Incorta SQL Select to create an Incorta SQL table using Incorta SQL engine Available as a lab feature as of release 5.0
    Derived Table → Materialized View Select to create a new materialized view using Apache Spark Prior to release 5.0, you can access this option from + NewMaterialized View
    + New → Join Select to access the Join Editor to create a new Left-Outer join relationship for an object in the physical schema where this object is the Child table. The join relationship can be with the object itself (self-join), with another object in the same physical schema, or with another object in another physical schema (cross-schema join)

    Summary/Header section

    The Summary/Header section shows the following information for the physical schema:

    Property Description
    Icon Represents the physical schema
    Name The physical schema name
    Description The physical schema description, if any
    Last Load Status The status of the last load job for the whole physical schema or for one of its entity objects, if any.
    This can be one of the following:
  • “Please load data” in the case that there are no previous or current load jobs for the physical schema
  • The timestamp for a successfully completed load job
  • Finished With Errors
  • Failed
  • Interrupted
    During a load job, this property shows the current state of the load job process:
  • In Queue
  • Extraction
  • Enrichment
  • Load
  • Post-load
    Select the link to access the Load Job Viewer and review load job details.
  • Loading Time The time taken to complete the last load job During a load job, the elapsed time is displayed
    Tables The number of the physical schema objects
    Joins The number of both child or parent join relationships related to the physical schema objects, if any
    Rows The total number of loaded rows available for Incorta for all the physical schema objects, that is, the physical schema rows in the Analytics Service in-memory Direct Data Mapping engine
    Data Size The total size of the physical schema files on disk including the Direct Data Mapping files and Parquet files

    Tables section

    In the case that there are no entity objects created for the physical schema, the Start adding tables to your schema: section is available with the options that you can access from the **+ New **menu in the Action bar. Use the available options to add the first entity object(s) to your physical schema.

    In the case that there are already entity objects created for the physical schema, the Tables section displays all the entity objects in the physical schema. Physical schema objects can be physical schema tables, aliases, Incorta Analyzer tables, Incorta SQL tables, or Materialized Views.

    The section header includes the following:

    • The number of the physical schema objects
    • Sort type: descending (an arrow pointing downwards) or ascending (an arrow pointing upwards). The default option is descending.
    • Sort property: the property to use for sorting the tables list. The following is the available options:

      • Name: alphabetical order
      • Columns: the number of columns
      • Joins: the number of joins
      • Rows: the number of rows
      • Data Size: default option

    For each physical schema object, the Tables section shows the following:

    • Action menu (v arrow): contains the following options:

      • Table Details: use to access the Table Editor to view or manage the properties of the physical schema object
      • Load Table: use to perform a full load for the object data. Not available in the case of an alias.
      • Load from Staging: use to perform a load for the object data from Shared Storage. Not available in the case of an alias
      • Remove Table: use to delete the physical schema object
    • The physical schema object properties

    The following table shows the properties of the physical schema object that the Tables section shows:

    Property Description
    Icon Represents either the type of the physical schema entity object or the type of the dataset in the case of a physical schema table.
    “Multiple” indicates that there are multiple data sources for the physical schema table.
    Table The object name
    Data Source/Source/Language One of the following:
  • The data source of a physical schema table
  • The fully qualified name of the source object for an alias
  • The code language for a materialized view
  • The type of the entity object: Incorta Analyzer or Incorta SQL table
  • Performance The status of object performance optimization:
  • Optimized
  • Not optimized Not available in the case of an alias.
  • Columns The number of columns in the physical schema object including both data-backed columns and formula columns
    Joins The number of both child or parent join relationships related to the physical schema object
    Rows The number of loaded rows for the physical schema object
    Data Size The size of the object files on disk including the Direct Data Mapping files and Parquet files
    Note

    During a running load job, the + New menu, Load, and Settings (gear icon) options are not available in the Action bar. In addition, the Action menu for each entity object in the Tables section shows only the Table Details option.

    Joins section

    The Joins section shows all join relationships related to the physical schema entity objects, whether they are self-join, schema join, or cross-schema join relationships.

    The section header includes the following:

    • The number of join relationships
    • Sort type: descending (an arrow pointing downwards) or ascending (an arrow pointing upwards). The default option is descending.
    • Sort property: the table to use for sorting the joins list: Child Table or Parent Table. The default is to sort by the Child Table name.

    For each join relationship, the Joins section shows the following:

    • Action menu (v arrow): this menu is available when the Child table in the join is in the current physical schema. The Action menu contains the following options:

      • Join Details: use to access the Join Editor to view or manage the join conditions and filters
      • Remove Join: use to remove the join relationship
    • Join conditions: each condition consists of three parts:

      • Child (the left side of the join): the physical schema, object, and the join column
      • Join operator
      • Parent (the right side of the join): the physical schema, object, and the join column
    Note

    Join filters do not appear in the Schema Designer.


    Schema Designer actions for a physical schema

    Using the Schema Designer, you can perform the following actions for a physical schema:

    Add or edit the physical schema description

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, select Settings (gear icon).
    • Select Edit Description.
    • In the Edit Description dialog, enter or update the physical schema description. You can enter up to 500 alphanumeric characters, including spaces and special characters.
    • Select Save.

    Search for a physical schema object

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, in the Search box, enter a search term.
    • In the result list, under Table Name, select the object that you want to open it in the Table Editor.

    Search for a column in physical schema objects

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, in the Search box, enter a search term.
    • In the result list, under Column Name, select the column to open the relative object in the Table Editor.

    Optimize the load performance for physical schema objects

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, select Settings (gear icon).
    • Select Performance Optimization.
    • In the Optimize Table Performance dialog, in the objects list, for each object you want to optimize the performance, select the check box, and for each object you do not want to optimize the performance, clear the check box.
    • Select Save.

    Change the load order for physical schema objects

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, select Settings (gear icon).
    • Select Change Load Order.
    • In the Choose Load Order dialog, you can do the following to manage the table groups before changing their load order:

      • For each table (or materialized view) that you want to add to a new load group, select the check box, and then select Add to New Group.
      • For each table (or materialized view) that you want to add to an existing load group, select the check box, and then select Add to Existing Group.
      • To reset table grouping and order, select Revert to Default.
    • To set the order of a table group, select the up arrow (to the right of the group name) to move the group upwards, or select the down arrow (to the right of the group name) to move the group downwards. Repeat this action until you order the table groups as required.
    • Select Save.

    Share the physical schema

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select Settings (gear icon).
    • Select Share.
    • In the Share dialog, you can do the following:

      • remove an existing user or group
      • modify the existing access rights for a user or group
      • add a new user or group with the required access rights

    Explore physical schema data

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select Explore Data.
    • Use the Analyzer to create insights referencing columns of the physical schema objects.

    Preview the physical schema join diagram

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select Diagram.
    • In the Schema Diagram Viewer, review the physical schema join relationships.

    Sort physical schema objects list view

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Tables section, select the arrow to point downwards to sort descending or to point upwards to sort ascending.
    • Select the property to sort by. The following is the available options:

      • Name (alphabetical order)
      • Columns (the number of columns)
      • Joins (the number of joins)
      • Rows (the number of rows)
      • Data Size (default)

    Schema Designer actions for load jobs

    With the Schema Designer, you can perform the following actions for data load jobs

    Perform a full load for physical schema data

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select LoadLoad NowFull.
    • In the dialog, select Load.

    Perform an incremental load for physical schema data

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select LoadLoad NowIncremental.
    • In the dialog, select Load.

    Load physical schema data from staging

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select LoadLoad NowStaging.
    • In the dialog, select Load.

    Schedule a physical schema load job

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select LoadSchedule.
    • In the Schedule Schema Load dialog, specify the scheduled load job properties.
    • In the Start On section, specify when the scheduled load job starts: select the date, time, and time zone.
    • In the Repeat section, specify the frequency of running the scheduled load job.

      • Select Daily, and then select how often this job runs: every number of minutes, hours, or days.
      • Select Weekly, and then select the week days to run the load job.
      • Select Monthly, and then select one of the following:

        • the day number every number of months (for example, the tenth day every 2 months)
        • a specific week day every number of months (for example, the second Monday every month)
      • Select the** No Recurrence** check box to run this job only once.
    • In the Repeat section, for repeated jobs, specify the end of the validity period of the scheduled load job:

      • Select No End to run it forever. This Is the default option.
      • Select End By, and then select a date to end the scheduled load job.
    • For Job Name, enter the name of the scheduled load job.
    • For Description, optionally, enter a description of the scheduled load job.
    • For Load Type, select the load type. The available options are:

      • Full
      • Incremental (default)
      • Staging
    • Select Schedule.
    Note

    The scheduled load jobs appear in the Scheduler, under Schema Loads. A user with the appropriate access rights to the Scheduler can manage these jobs, in addition to creating new jobs.

    Perform a full load for physical schema object data

    This option is not available for an alias.

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Tables section, for a given object, in the Action menu (v arrow), select Load Table.
    • In the dialog, select Load.

    Load physical schema object data from staging

    This option is not available for an alias.

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Tables section, for a given object, in the Action menu (v arrow), select Load from Staging.
    • In the dialog, select Load.

    Review the status of a load job

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Summary section, select the Last Load Status link.
    • In the Load Job Viewer, review the load job status.

    Create a physical schema load email notification

    Important

    Notifications require a tenant email configuration for an outgoing email server using SMTP or EWS in the Cluster Management Console (CMC).

    The notifications that you create appear on the Scheduler, under Schema Notifications. A user with the appropriate access rights to the Scheduler can manage these notifications, in addition to creating new notifications.

    Here are the steps to create an email notification for a physical schema:

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select Settings (gear icon).
    • Select Create Notification.
    • In the Create Email Notification dialog, enter the details of the email notification. For more information, see [Email notification details].
    • Select Done.

    Email notification details

    The following table shows the details you need to specify for a load email notification:

    Property Control Description
    Notification Name text box Enter the name of the new email notification. The length of the notification name must be between 1 and 255 alphanumeric characters, including spaces and special characters.
    Notify On → Success checkbox Select the checkbox to send the notification email when the load successfully completes
    Notify On → Failure checkbox Select the checkbox to send the notification email when the load fails
    Select Schema(s) → Search text box Enter a search term to search for specific physical schemas to create load notification for.
    Select Schema(s) → Select All checkbox Select the checkbox to select all physical schemas you have access to or all physical schema(s) in the search result list
    Select Schema(s) → Schemas list list/checkbox Select the checkbox for each physical schema you want to include in the load notification. Only physical schemas that you own or have access rights to appear on the list.
    Recipients → Search Names, Emails, and Groups text box
  • Enter a search term (for example, an email address, user name, group name) to search for users or groups in the tenant.
  • Enter the email address to select an external recipient.
  • Recipients → List list For each recipient, select V (down arrow) to the right of the recipient name or email, and then select where the given recipient should go to: the To list, Cc list, or Bcc list.
    Body text box Optionally, enter the email body text. The body text you enter appears in the notification email before an auto-generated text. You can enter up to 4000 alphanumeric characters, including spaces and special characters.
    Note

    When you create an email notification that contains multiple physical schemas, the recipient(s) receives a separate email for each physical schema. Recipients on the Bcc list do not appear on the received email, while those on the To and Cc lists do appear.

    The notification email contains the following:

    • the email body text you entered, if any
    • the notification name
    • the display name of the notification user creator
    • the schema name
    • the schema load status
    • the load date and time
    • the load duration
    • a link to the Load Job Viewer that contains the schema load job summary and details

    Schema Designer actions for a physical schema object

    Using the Schema Designer, you can perform the following actions for physical schema objects:

    Create one or more physical schema tables using the Schema Wizard

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select + New → Schema Wizard.
    • In (1) Choose a Source, for Select a Datasource, select the external data source for your new physical schema table(s).
    • In the Schema Wizard footer, select Next.
    • In (2) Manage Tables, in the Data Panel, specify the table(s) or file(s) you want to use to create the new physical schema tables. You can also select the Select All checkbox.
    • In the Schema Wizard footer, select Next.
    • In (3) Finalize, in the Schema Wizard footer, select Update Schema.

    To learn more about using the Schema Wizard, review Tools → Schema Wizard.

    Note

    You cannot control the name of a physical schema table that you create using the Schema Wizard. The physical schema table automatically inherits the name of the data source table, file name, or worksheet name.

    Create a physical schema entity object

    Important: Validation Rules for a physical schema entity object name

    An entity object name…

    • must be between 1 and 128 characters in length
    • must begin with an alpha character (lower or upper case), underscore (_), or Dollar sign ($) character
    • after the first character, can contain zero or more alphanumeric characters in lower, upper, or mixed case
    • besides underscore (_) and Dollar sign ($) characters, cannot contain special characters, symbols, or spaces
    • must be unique at the schema level
    • is case-sensitive

    Create a physical schema table

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select + NewTable → the data source type.
    • In the Table Editor, in the Data Source dialog, specify the properties of the new physical schema table.
    • Select Add.
    • In the Table Editor, for Table Name, enter the name of the new physical schema table.
    • In the Table Editor, in the Action bar, select Done.

    To discover more about the properties of different data sources, see Connectors → All, and refer to the suitable connector.

    Create an alias

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select + NewAlias.
    • In the Table Editor, for Table Name, enter the name of the new alias.
    • In the Table Editor, in the Data Source(s) section, for Schema Name, select the physical schema of the original entity object that this alias references. This can be the current physical schema or another physical schema. The default is the current physical schema.
    • For Select Table, select the original entity object that this alias references.
    • In the Action bar, select Done.

    Create an Incorta Analyzer table

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select + NewDerived TableIncorta Analyzer Table.
    • In the Table Editor, in the Data Source dialog, select the pen icon.
    • In the Analyzer, select the columns in the new Incorta Analyzer table and specify their properties.
    • In the Analyzer, select Save.
    • In the Data Source dialog, review the sample data, and then select Add.
    • In the Table Editor, for Table Name, enter the name of the new Incorta Analyzer table.
    • In the Table Editor, in the Action bar, select Done.

    To learn more about the Analyzer, review Tools → Analyzer.

    Create an Incorta SQL table

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select + NewDerived TableIncorta SQL Table.
    • In the Table Editor, in the Data Source dialog, in the Query section, select the pen icon.
    • In the Query Editor, enter the SQL code for the new table, and then select Done.
    • In the Data Source dialog, select Add.
    • In the Table Editor, for Table Name, enter the name of the new Incorta SQL table.
    • In the Table Editor, in the Action bar, select Done.

    Create a materialized view

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Action bar, select + NewDerived TableMaterialized View.
    • In the Table Editor, in the Data Source dialog, specify the properties of the new object.
    • Select Add.
    • In the Table Editor, for Table Name, enter the name of the new materialized view.
    • In the Table Editor, in the Action bar, select Done.

    To discover more about the properties of a materialized view, see Concepts → Materialized View.

    View physical schema object details

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Tables section, for a given physical schema object, do one of the following:

      • Select the physical schema object.
      • In the Action menu (v arrow), select Table Details.
    • In the Table Editor, review the object properties.
    • To exit the Table Editor without saving updates, if any, in the Action bar, select Cancel.

    Edit a physical schema object

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Tables section, for a given physical schema object, do one of the following:

      • Select the physical schema object.
      • In the Action menu (v arrow), select Table Details.
    • In the Table Editor, make the necessary updates.
    • To save updates, in the Join Editor, in the Action bar, select Done.

    To learn more about using the Table Editor, review Tools → Table Editor.

    Delete a physical schema object

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Tables section, for a given physical schema object, in the Action menu (v arrow), select Remove Table.
    • In the dialog, clear or keep selected the Remove all joins related to this table checkbox, as appropriate, and then select Remove.

    Schema Designer actions for a join relationship

    Using the Schema Designer, you can perform the following actions for join relationships:

    Note

    You can edit a join relationship, view its properties, or remove it only when you use the Schema Designer for the physical schema of the Child table in the join.

    Create a join relationship

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, do one of the following:

      • If there are no existing joins for the physical schema, in the Joins section, select Create new join.
      • In the Action bar, Select + NewJoin.
    • In the Join Editor, for the new join relationship, specify the join properties for the Child and Parent sides.
    • In the Join Editor, in the Action bar, select Done.

    Sort joins list view

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Joins section, select the arrow to point downwards to sort descending or to point upwards to sort ascending.
    • Select whether to sort by the alphabetical order of the Child Table name, which is the default option, or the Parent Table name

    View join relationship properties

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Joins section, for a given join relationship, do one of the following:

      • Select the join relationship.
      • In the Action menu (v arrow), select Join Details.
    • In the Join Editor, review the join conditions and filters, if any.
    • To exit the Join Editor without saving updates, if any, in the Action bar, select Cancel.

    Edit a join relationship

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, in the Joins section, for a given join relationship, do one of the following:

      • Select the join relationship.
      • In the Action menu (v arrow), select Join Details.
    • In the Join Editor, make the necessary updates.
    • To save updates, in the Join Editor, in the Action bar, select Done.

    Remove a join relationship

    • In the Navigation bar, select Schema.
    • In the list view of schemas, select a given physical schema.
    • In the Schema Designer, for a given join relationship in the Joins section, in the Action menu (v arrow), select Remove Join.
    • In the dialog, select Remove.

    © Incorta, Inc. All Rights Reserved.