You are viewing content for 5.1 | 5.0 | 4.9 | 4.8 | 4.7 | 4.6 | 4.5 | 4.4 | 4.3 | Previous Releases


Tools → Scheduler

About the Scheduler

The Scheduler allows you to both manage the scheduled jobs for dashboard delivery and create and manage scheduled jobs for physical schema loads, data notifications, and schema notifications.

Incorta sends the scheduled dashboards, data notifications (dashboard alerts), or schema notifications in an email to the recipients you specify. You can also deliver a dashboard to a Data Destination.

Scheduler access rights

To access the Scheduler, in the Navigation bar, select Scheduler.

All Incorta Analytics users can access the Scheduler, but not all users can create or manage scheduled jobs. Only users who created or have edit rights to a dashboard can edit a scheduled job for a dashboard delivery. The users who create or have edit rights to a schema can create and manage a scheduled schema load.

Note

If you do not have edit rights and did not create a schema, the +New button is disabled.

Scheduler Anatomy

The Scheduler consists of the following:

Context Bar

The context bar consists of the four tabs:

  • Dashboards: contains a list of the scheduled dashboards deliverables
  • Schema Loads: contains a list of the scheduled schema loads
  • Data Notifications: contains a list of the configured data notifications (dashboard alerts)
  • Schema Notifications: contains a list of the configured schema notifications

Action Bar

The action bar consists of:

  • +New

The +New button opens the +New menu, which may vary from one tab to the other.

Tab name +New menu item(s) description
Schema Loads Add Schema Load - Select to add a new scheduled schema load job.

Data Notifications Create Notifications - Select to create a new dashboard notification.

Import Notifications - Select to import existing .zip data notifications file(s).

Schema Notifications Create Email Notifications - Select to create a new email notification upon a schema load success or fail.
Note

The +New button is not available in the Dashboards tab. You create a dashboard delivery scheduled job from the Content Manager.

The Search bar contains a search text box that is only available in the Schema Notifications tab. You can search for any part of a given job name.

The Search bar shows:

  • The number of items in the result list
  • The number of selected items in the result list with the option (x) to deselect the items
  • Delete icon, to delete all selected items
  • Export icon, to export Data Notifications (only available in the Data Notifications tab)

List View

Dashboards list view

The Dashboards list view displays all of the scheduled delivery jobs that you created for a certain dashboard.

Property Control Description
Select All check box A header control to select all scheduled jobs for dashboard delivery.
Name text The scheduled job unique name that you entered while creating the scheduled dashboard delivery.
Owner text The username that created the scheduled dashboard delivery.
Dashboard link Select the dashboard name to navigate to the corresponding dashboard.
Status link The status of the scheduled job. When selected, a prompt is displayed to confirm if you want to suspend/activate the scheduled delivery job.
A scheduled delivery status can be one of the following:
  • Active
  • Suspended
  • Completed (if it is scheduled for one-time delivery)
    When you create a scheduled dashboard delivery, Status is Active by default.
  • Status filter (funnel icon) drop down menu A drop down menu that contains all possible statuses of a scheduled delivery. By default, the list is filtered by the Active status.
    Use this drop down to filter the list with a certain status.
    The drop down contains two buttons:
  • OK - to apply the filter
  • Reset - to clear any filtration applied
  • Next Run text The date, time, and time zone for when a scheduled job will run.
    Delete (trash icon) button Select to delete the scheduled delivery.
    Note

    When you select the name of a scheduled dashboard delivery, it opens the Schedule form, where you can edit the scheduled job details.

    Schema Loads list view

    The Schema Loads list view displays all scheduled schema load jobs that you created from the Scheduler or from the Schema tab.

    Property Control Description
    Select All check box A header control to select all scheduled jobs for schema loads.
    Name text The scheduled job unique name that you entered while creating the scheduled schema load.
    Owner text The username that created the scheduled schema load.
    Schema link Select the schema name to navigate to the schema for which the scheduled load job is created.
    Status link The status of the scheduled job. Select to change the status of the scheduled load.
    A scheduled schema load status can be one of the following:
  • Active
  • Suspended
  • Completed (if it is scheduled for a one-time load)
    When you create a scheduled schema load, Status is Active by default.
  • Status filter (funnel icon) drop down menu A drop down menu that contains all possible statuses of a scheduled schema load. By default, the list is filtered by the Active status.
    Use this drop down to filter the list with a certain status.
    The drop down contains two buttons:
  • OK - to apply the filter
  • Reset - to clear any filtration applied
  • Next Run text The date, time, and time zone for when a scheduled schema load job is to run next.
    Delete (trash icon) button Select to delete the scheduled schema load.
    Note

    When you select the name of a scheduled schema load, it opens the Edit Schema Load form, where you can edit the scheduled schema load details.

    Data Notifications list view

    The Data Notifications list view displays all scheduled dashboard data notifications (alerts) that you created from the Scheduler or from the Set Alert option in a dashboard.

    Property Control Description
    Select All check box A header control to select all scheduled data notifications.
    Name text The scheduled job unique name that you entered while creating the scheduled alert.
    Owner text The username that created the scheduled data notifications.
    Target link Select the dashboard name to navigate to the dashboard for which the scheduled alert is created.
    Status link The status of the scheduled job. When you select it, a prompt is displayed to confirm if you want to change the status of the scheduled data notification.
    A scheduled data notification status can be one of the following:
  • Active
  • Suspended
  • Completed (if it is scheduled for a one-time notification)
    When you create a scheduled data notification, Status is Active by default.
  • Status filter (funnel icon) drop down menu A drop down menu that contains all possible statuses of a scheduled data notification. By default, the list is filtered by the Active status.
    Select to filter the list with a certain status.
    The drop down contains two buttons:
  • OK - to apply the filter
  • Reset - to clear any filtration applied
  • Next Run text The date, time, and time zone for when a scheduled data notification is to run next.
    Delete (trash icon) button Select to delete the scheduled data notification.
    Export button Select to export the selected data notification to a .zip file that you can use later on to import the scheduled data notification again.
    Note

    When you select the name of a scheduled data notification, it opens the Alert Editor form, where you can edit the data alert details.

    Schema Notifications list view

    The Schema Notifications list view displays all email alerts that you created for a schema.

    Property Control Description
    Select All check box A header control to select all scheduled email notifications.
    Name text The scheduled notification unique name that you entered while creating the alert.
    Schema(s) text Schema(s) name(s) for which you created the email alert.
    Last Modified text The date and time for when the email notification was last modified.
    Edit (pen icon) button Select to edit the email notification.
    Delete (trash icon) button Select to delete the scheduled data notification.

    Scheduler Actions

    Using the Scheduler, you can perform the following actions:

    Dashboard

    Edit scheduled Dashboards

    To schedule a dashboard for delivery, use the Content Manager. For more information, refer to Schedule Delivery of the Dashboard.

    You can edit a scheduled dashboard delivery job through the Scheduler using the following steps:

    • Select a scheduled Dashboard job.

      • The Schedule: <dashboard-name> edit tool opens.
    • Edit the details of the scheduled job.
    • Select Save changes.

    Schema Loads

    Create scheduled Schema Loads

    You can schedule a job to load a certain schema from the Schema Manager.

    You can also create a scheduled job from the Scheduler by applying the following steps:

    • Open the Scheduler.
    • Go to the Schema Loads tab.
    • From the Action bar, select + New → Add Schema Load.

      The Add Schema Load form opens.

    • Fill in the following options in the form to schedule the Schema Load job.
    Property Control Description
    Schema Load Name text box Enter a unique name for the Schema Load job you are creating.
    Description text box Enter a description for the Schema Load job.
    Schema drop down menu Select the desired Schema to schedule a load job.
    The list only displays the available schema(s) that you can edit.
    Load Type drop down menu Select the type of the load you want to perform. The type of loads are:
  • Full
  • Incremental (default)
  • Staging
  • Every increments and drop down menu Select the recurrence of the load job by selecting an interval of minutes, hours, days, weeks, or months.
    This option is disabled when you select the No recurrence checkbox.
    No recurrence checkbox Select the checkbox to schedule the load job for one time only.
    This option is unselected by default.
    Starting at / At time and time zone selection Select the time and time zone desired to schedule the Schema Load job.
    The option name changes to At when you select the No recurrence checkbox.
    Starting at / At → Now button (Optional) Select Now in the time drop down menu to choose current local time.
    Starting at / At → Ok button Select to confirm the time you chose.
    From / On calendar Select the date range of the Schema Load job.
    The field name changes to On when you select the No recurrence checkbox.
    Does not end checkbox Select this check box to disable the end date of the load job.
    Not available when you select the No recurrence checkbox.
    Add button Select to save the form and add the scheduled job to the list.
    Cancel button Select to cancel what you have entered and close the form.

    Edit scheduled Schema Loads

    You can edit a scheduled Schema Load through the Scheduler using the following steps:

    • In the Schema Loads tab, Select a scheduled Schema Load job.

      • The Edit Schema Load form opens.
    • Edit the details of the scheduled job.
    • Select Save.

    Data Notifications

    Create scheduled Data Notifications

    You create a data notification (alert) for a certain dashboard from the dashboard itself and from the Scheduler. When you create an alert, you set a condition. When this condition returns data, the alert job sends the dashboard.

    Do the following steps to create a data alert through the Scheduler:

    • Open the Scheduler.
    • Go to the Data Notifications tab.
    • From the Action bar, select +NewCreate Notifications.

      The Alert Editor tool opens.

    • Fill in the following options in the form to create a data notification job.
    Property Control Description
    Name text box Enter the name of the data notification job you are creating.
    Description text box Enter a description for the data notification job.
    Type radio button Select the type of the attachment you want to send.
    Available type of attachments:
  • HTML
  • XSLX
  • CSV
  • Target selection Select the dashboard you want to create the Data Notification for.
    Condition → (pen icon) button Select the edit button for the Condition section to open the Analyzer and create a condition for the alert.
    Condition table Displays the output of the condition you create in the Analyzer.
    Start by date and time Select the date and time for the alert to start working.
    Recurrence radio button Select the recurrence of the alert to be one of the following:
  • Daily
  • Weekly
  • Monthly
  • No Recurrence
  • Recurrence → Every increments and drop down menu Select the number of recurrences per day, week, or month.
    This option is not available when you select the No Recurrence option.
    Recurrence → No End radio button Select to keep the alert active with no end date.
    Recurrence → End by radio button Select to set an end date for the alert to be completed.
    Send To list List of emails the dashboard is sent to.
    Send To → + button Select to open the Send to form.
    Send To → + → Add button Search names, groups, or emails, and then select Add to add them to the list of Send To emails.
    Send To → + → Cancel button (Optional) Select to close the Send to form and cancel any selection.
    • From the Action bar, select Done to save the alert.

    Edit scheduled Data Notifications

    You can edit a scheduled data notification (alert) through the Scheduler using the following steps:

    • Select a scheduled alert job.

      • The Alert Editor form opens.
    • Edit the details of the scheduled alert.
    • Select Done.

    Export Data Notifications

    The Scheduler enables you to export Data Notifications you created to be able to import them later on.

    You can export Data Notifications by applying the following steps:

    • To export one scheduled job:

      • Hover on or select a scheduled data notification.
      • Select the Export button.

        The Scheduler downloads a .zip file to your machine.

    • To export multiple scheduled jobs:

      • Select multiple scheduled data notifications.
      • Select the Export button.

        The Scheduler downloads a .zip file to your machine.

    Import Data Notifications

    The Scheduler enables you to import .zip files that contain Data Notifications. You can import Data Notifications by performing the following steps:

    • From the Action bar, select + NewImport Data Notifications.

      • The Import Alerts window opens.
    • Select Overwrite existing alerts option if you want to delete any alerts that you created before and create new ones.
    • Browse to, or drag and drop, the .zip file that contains the notifications you want to import.

    Schema Notifications

    Create Schema Notifications

    You can create an email alert for one or multiple certain schemas. The alert that you create is triggered upon the success or failure of a schema load.

    Perform the following steps to create the data alert:

    • Open the Scheduler.
    • Go to the Schema Notifications tab.
    • From the Action bar, select + NewCreate Email Notifications.

      The Create Email Notification form opens.

    • Fill in the following options in the form to create a schema notification job.
    Property Control Description
    Notification Name text box Enter the name of the email notification job you are creating.
    Notify on multi-select Select when you want to send the email notification.
    There are 2 possible values:
  • Success
  • Failure (Default)
  • Select Schema(s) multi-select Select one or multiple schemas you want to send an alert for.
    Recipients text box Enter the email, name, or group of recipients you want to send the email notification to.
    Body text box (Optional) Enter the body for the email notification job you are creating.
    If you did not enter a body for the email notification, Incorta sends a body with auto-generated text that contains the sender name, the schema name, its status, and URL.
    • Select Done to save the email notification.

    Edit Schema Notifications

    You can edit a scheduled schema notification (alert) through the Scheduler using the following steps:

    • Select a scheduled alert job.

      • The Edit Email Notification form opens.
    • Edit the details of the scheduled alert.
    • Select Done.

    Search the list of Schema Notifications

    The Scheduler enables you to search the list of Schema Notifications through the search bar available in the list view.

    To search for a scheduled schema notification:

    • Open the Scheduler, and go to the Schema Notifications tab.
    • In the search bar, enter the schema notification job name.

      • The search result is displayed according to the keyword you entered.
    Note

    You can only search the Schema Notifications list using the schema notification job name.

    Common Actions

    Suspend and Activate scheduled jobs

    In the Scheduler, you can activate or suspend a scheduled job for the following:

    • Dashboards
    • Schema Loads
    • Data Notifications

    When you create a scheduled job, its status is Active by default. If you need to suspend it, do the following steps:

    • For a scheduled job, select the Active status.

      • Confirm Changing Status window will appear.
    • Select Ok to confirm changing the status of the job from Active to Suspended.
    Note

    You can select Never Mind to cancel.

    Delete scheduled jobs

    The Scheduler enables you to delete one or multiple scheduled jobs.

    To delete one scheduled job:

    • Select or hover on a scheduled job.
    • Select the Delete button (bin icon).

      • The Delete this job? confirmation window appears.
    • Confirm deleting the job by selecting Delete.

    To delete multiple scheduled jobs:

    • Select multiple scheduled jobs.
    • Select the Delete button (bin icon).

      • The Delete these jobs? confirmation window appears.
    • Confirm deleting the job by selecting Delete.
    Note

    You can select Never Mind to cancel.

    Filter scheduled jobs

    You can filter the list of the scheduled jobs for the following according to their status:

    • Dashboards
    • Schema Loads
    • Data Notifications

    A scheduled job can have one of three statuses:

    • Active (default) - Indicates that the job is active and will run according to schedule
    • Suspended - Indicates that the job is on hold and will not run
    • Completed - Indicates that the job was a one time job only and was completed successfully
    Important

    By default, the list displays the jobs with Active status only.

    To filter the list of scheduled jobs, do the following:

    • Select the Status filter (funnel icon).
    • Select the status(es) you want to filter the list with.
    • Select OK.

      • The list will only display the jobs that have the status(es) you selected.
    Note

    You can select Reset to clear any selection and show only the jobs with Active status.

    Create a Data Notification example

    Assuming you created a Dashboard named Sales Insight for the SALES schema, the following is an example to create a data notification (alert) for this dashboard.

    Important

    You must have the email configuration set for your tenant in the CMC. Refer to Tenant Configurations for more information.

    In this example, you will create an email alert for the Sales Insight dashboard to be sent everyday to your email if the cost of the goods is less than 500.

    • Open the Scheduler and go to the Data Notifications tab.
    • Select + NewCreate Notifications.

      • The Alert Editor window opens.
    • Fill in the Name field to be: Sales Insight Alert.
    • (Optional) Add a description to this alert in the Description field.
    • Select the Type of the attachment to be HTML.
    • In the Target field, select the pen icon, and then navigate to the Sales Insight dashboard.
    • Select Tab1, and then select Add.
    • For the Condition field, select the pen icon to open the Analyzer:

      • In Data, select Add Data Set, expand the SALES schema, and then select the SALES table.
      • Drag and drop the Sales Date column to the Grouping Dimension tray.
      • Drag and drop the Cost column to the Measure tray, and change the format to Dollar.
      • Drag and drop Add Formula to the Individual Filter tray.
      • Add the following formula in the Formula Builder:

        SALES.SALES.COST_OF_GOODS < 500
      • Select Validate & Save.
      • Change the Column Label to be Cost less than 500.
      • Select Save.
    • Select the Start By field to be today’s date and the current time on your machine.
    • Select the Recurrence to be Daily, Every 1 day, and No End for example purposes.
    • In the Send To field, select +:

      • Add your email address.
      • Select Add.
    • Select Done.

    © Incorta, Inc. All Rights Reserved.