You are viewing content for 5.1 | 5.0 | 4.9 | 4.8 | 4.7 | 4.6 | 4.5 | 4.4 | 4.3 | Previous Releases


Tools → Business Schema Designer

About the Business Schema Designer

The Business Schema Designer allows you to create, edit, and delete a runtime business view. There are two types of runtime business views for a business schema: a business schema view and an Incorta View. The Business Schema Designer allows you to manage both types of views. You need to have the suitable permissions and access rights to access the Business Schema Designer and manage runtime business views.

To learn more about runtime business views, review Concepts → Runtime Business View .

To learn more about Incorta Views, review Concepts → Incorta View .

To learn more about business schema views, review Concepts → Business Schema View .

Business Schema Designer permissions and access rights

A user that belongs to a group with the Schema Manager or the SuperRole role can access the Business Schema Designer. However, the user has to own or have Edit access rights to a business schema to be able to use the Business Schema Designer to edit it.

To access the Business Schema Designer for an existing business schema, you must first open the business schema from the Business Schema Manager:

  • In the Navigation bar, select Business Schema.
  • In the list view, select the business schema.

When you crate a new business schema using the Business Schema Manager, the Business Schema Designer automatically opens in view mode.

Note

The Business Schema Designer opens by default in view mode.

Business Schema Designer modes

The Business Schema Designer supports two different modes: view mode and edit mode.

View mode

The view mode is the default mode. In the view mode, you can perform the following actions:

  • search the business schema for a folder, view, or column
  • explore the business schema data
  • select to create a new folder or view. This opens the Business Schema Designer in edit mode.
  • view the business schema summary
  • expand or collapse a folder or view
  • view runtime business views in a folder
  • view columns in a runtime business view
  • select to edit a folder or view. This opens the Business Schema Designer in edit mode.

Edit mode

Important

You can access the Business Schema Designer in edit mode only for Business Schemas that you own or have Edit access rights to.

Here are the steps to access the Business Schema Designer edit mode:

  • In the Navigation bar, select Business Schema.
  • In the Business Schema Manager, select a given business schema.
  • In the Business Schema Designer, do one of the following:

    • If this is the first view in the business schema, in the Canvas, select Add New View.
    • In the Action bar, select +NewAdd New View.
    • In the Action bar, select +NewAdd New Folder.
    • In the Canvas, for a given folder or view, select More Options (⋮ vertical ellipsis), and then select Edit.

In the Business Schema Designer edit mode, you can perform the following actions:

  • create a new folder or business schema view
  • select to create an Incorta View
  • view the business schema summary
  • save changes and exit the edit mode
  • cancel changes and exit the edit mode
  • expand or collapse a folder or view
  • edit a folder or view
  • delete a folder or a view
  • manage runtime business views in a folder
  • manage columns and formula columns in a runtime business view, as applicable
  • display the Edit panel
  • use the Data panel to add columns or formula columns to a business schema view

Business Schema Designer anatomy

The Business Schema Designer consists of the following:

  • Action bar
  • Summary section
  • Canvas
  • Data panel
  • Edit panel

Action bar

The Action bar shows the following:

  • Search: enter a search term to search for a runtime business view, folder, or column in the business schema. Select an item from the search list to expand the related runtime business view or folder in the Canvas. The search feature is available in the Business Schema Designer view mode only.
  • Explore Data: select to access the Analyzer to explore the business schema data. This feature is available in the Business Schema Designer view mode only.
  • +New: select to open the Add New menu. The Add New menu options are:

    • Add New Folder: select to create a new folder in the business schema
    • Add New View: select to create a business schema view or Incorta View
  • Done: available when you add or edit a folder or a runtime business view. Select to save the changes you made and exit the Business Schema Designer edit mode.
  • Cancel: available when you add or edit a folder or a runtime business view. Select to cancel the changes you made and exit the Business Schema Designer edit mode.

Summary section

The Summary section shows the name and description of the business schema, in addition to the number of folders and views in the Business Schema. Views in folders are not counted in the displayed number.

Canvas

The Canvas shows folders, business schema views, and Incorta Views in a given business schema. You can use the Canvas to perform different actions depending upon the Business Schema Designer mode: view mode or edit mode.

The Canvas contains the following:

  • Title bar: shows the name of the view or folder and number of items
  • More Options (⋮ vertical ellipsis): select to open the More Options menu. Available options depend on the Business Schema Designer mode.
  • Folders and views tree

Title bar

The Title bar shows the name of the view or folder. In addition to the name, the Title bar shows the following:

  • For a folder, it shows the number of runtime business views in the folder.
  • For a runtime business view, it shows the number of columns and formula columns in the runtime business view. In the case that the business schema view has a base table, a B icon appears next to the number of columns. Hover over the B icon to view the selected base table.

You can use the Title bar to edit the folder or view name and also to create a view in a given expanded folder.

More Options menu

The More Options menu contains different options for folders and views. The Edit option for a folder or a runtime business view is available only in the view mode.

  • The More Options menu for a folder shows the following options:

    • Edit: select to open the Business Schema Designer edit mode. This is the only available option in the Business Schema Designer view mode.
    • Empty: select to move all runtime business views from the folder
    • Delete: select to delete the folder and all its runtime business views
  • The More Options menu for a runtime business view shows the following options:

    • Edit: select to open the Business Schema Designer edit mode. This is the only available option in the Business Schema Designer view mode.
    • Edit View Info: to edit the runtime business view name and description
    • Edit in Analyzer: to edit the Incorta View in the Analyzer
    • Move To Folder: to move the runtime business view to a folder
    • Move Out of Folder: to move the runtime business view from a folder
    • Clear All: to remove all columns in the runtime business view
    • Set Base Table: to specify the base table for the business schema view
    • Delete: to delete the runtime business view

Folders and views tree

The Canvas shows the business schema folders and views as a tree that represents a hierarchy:

–– folder (if any)

–––– runtime business view

–––––– column

You can expand or collapse each folder or view: select > (caret or chevron right icon) or the V (caret or chevron down icon) respectively.

The tree shows the following details for an expanded runtime business view:

  • For a column in a business schema view, it shows the Name, Label, Description, and fully qualified name of the Source Column.
  • For a formula column in a business schema view, it shows the Name, Label, Description, Function, and Formula.
  • For a column in an Incorta View, it shows the Name, Label, Data Type, and Function.

When you expand a folder or view, you can perform different actions:

  • When you expand a folder in the tree, you can:

    • create a runtime business view in the folder (select + in the folder Title bar)
    • order runtime business views in the folder
    • drag and drop a runtime business view to or out from the folder
  • When you expand a business schema view in the tree, you can:

    • add columns from the Data panel to the expanded business schema view
    • add formulas from the Data panel to the expanded business schema view
    • edit column properties:

      • Name
      • Label
      • Description
    • edit formula column properties:

      • Name
      • Label
      • Description
      • Function
      • Set Formula or Change Formula
    • view column details and sample data for a column in a business schema view
    • order columns and formula columns in the business schema view
    • delete a column or formula column from a business schema view

Data panel

The Data panel shows columns in selected physical schema tables to use for business schema views. The Tree in the Data panel represents a hierarchy:

–– physical schema

–––– table

–––––– column

In the Tree, next to the column name, a light blue circle indicates a Dimension or Key column whereas a dark blue circle indicates a Measure column.

Use the Data panel to:

  • expand all in tree or collapse all in tree
  • search for specific tables or columns in one or more schemas
  • open the Edit panel (select + to open)
  • collapse and expand the tree of columns
  • view the details of a column
  • preview the data for a column
  • add a formula to a business schema view (drag and drop to the view canvas)
  • add a column to a business schema view (drag and drop to the view canvas)

Edit panel

Use the Edit panel to select an entire schema, select a table, or search for a specific table. Search in the Edit panel does not support finding specific columns.

Here are some of the options available in the Edit panel:

  • select tables or schemas
  • search for a table
  • tree to select schema(s) / table(s)
  • Done (to save selection)

Business Schema Designer actions for a business schema

With the Business Schema Designer, you can perform the following actions for a business schema:

Explore the business schema data

  • In the Navigation bar, select Business Schema.
  • In the Business Schema Manager, select a given business schema.
  • In the Business Schema Designer view mode, in the Action bar, select Explore Data.
  • Use the Analyzer to do one of the following:

    • create an insight referencing columns or formula columns in runtime business views in the business schema and/or other business schemas, in addition to tables in physical schemas
    • create and save a business schema view in the current business schema or other business schemas referencing columns and formula columns in physical schema tables

For more information about how to use the Analyzer to create insights or business schema views, please review Tools → Analyzer.

Note

The Save as Business View option is available starting from release 5.0. This option is available only for a Listing Table insight.

Edit the business schema

  • In the Navigation bar, select Business Schema.
  • In the Business Schema Manager, select a given business schema.
  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • Use the Business Schema Designer in edit mode to add or edit runtime business views and folders in the business schema.
  • In the Action bar, select Done.

For more information about the actions that you can perform for a folder, see Business Schema Designer actions for folders.

For more information about the actions you can perform for a runtime business view, see Business Schema Designer actions for runtime business views.


Business Schema Designer actions for runtime business views

With the Business Schema Designer, you can perform the following actions for runtime business views:

Important

Validation Rules for a runtime business view name

A runtime business view name…

  • Must be unique at the business schema level: no 2 views or more can share the same name; however a view and a folder can share the same name in the business schema
  • Must be at least 1 character in length
  • Must begin with an alpha character, lower or upper case
  • After the first alpha character, can contain zero or more alphanumeric characters in lower, upper, or mixed case
  • After the first alpha character, can contain zero or more underscore (_) or Dollar sign ($) characters
  • Besides underscore (_) and Dollar sign ($), cannot contain special characters, symbols, or spaces

Create a new business schema view

  • In the Navigation bar, select Business Schema.
  • In the Business Schema Manager, select a given business schema.
  • If this is the first view in the business schema, in the Canvas, select Add New View; otherwise, in the Action bar, select +NewAdd New View.
  • In the Business Schema Designer, in the Canvas, do any or all of the following:

    • Drag and drop columns from the Data panel to the business schema view, and for each column, specify the column properties as required. For more information, review Concepts → Business Schema View Column.
    • Drag and drop a formula from the Data panel to the business schema view canvas, select the function of the formula column (Dimension or Measure), select Set Formula, and use the Formula Builder to create the formula column. For more information, review Concepts → Business Schema View Formula Column.
    • To remove a given column or formula column from the business schema view, hover over the row, and then select Delete (trash can icon).
    • Select the view name, edit it, and then select any other place in the Business Schema Designer.
  • In the Action bar, select Done.

Create a new Incorta View

  • In the Navigation bar, select Business Schema.
  • In the Business Schema Manager, select a given business schema.
  • If this is the first view in the business schema, in the Canvas, select Add New View; otherwise, in the Action bar, select +NewAdd New View.
  • In the Business Schema Designer, in the Canvas, select Create in Analyzer.
  • Use the Analyzer to create and save the new Incorta View. For more information about how to use the Analyzer to create an Incorta View, review Tools → Analyzer.
  • Select the view name, edit it, and then select any other place in the Business Schema Designer.
  • In the Action bar, select Done.

Edit a business schema view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, expand the business schema view and make the necessary changes:

    • To add a new column, drag and drop a column from the Data panel to the business schema view. For more information, review Concepts → Business Schema View Column.
    • To add a formula column, drag and drop a formula from the Data panel to the business schema view, select Set Formula, and use the Formula Builder to create the formula column. For more information, review Concepts → Business Schema View Formula Column.
    • To edit the properties of a column or formula, change the name, label, and/or description of the column or formula.
    • To change the formula of a formula column, select Change Formula, and use the Formula Builder to update the formula column. For more information, review Concepts → Business Schema View Formula Column.
    • To change the function of a formula column, for Source Column/Formula, select Dimension or Measure.
    • To order columns or formula columns in the business schema view, drag and drop a given column or formula column to the place you want in the business schema view.
    • To remove a given column or formula column from the business schema view, hover over the row, and then select Delete (trash can icon).
  • In the Action bar, select Done.

Edit an Incorta View

You can edit an Incorta View only in the Analyzer.

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given Incorta View, select More Options (⋮ vertical ellipsis).
  • Select Edit in Analyzer.
  • In the Analyzer, make the required changes, and then select Save.
  • In the Action bar, select Done.

Rename a runtime business view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given view, in the Title bar, select the view name, and edit it.
  • Select any other place in the Business Schema Designer.
  • In the Action bar, select Done.

You can also change the name when editing the runtime business view info.

Edit runtime business view info

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given view, select More Options (⋮ vertical ellipsis).
  • Select Edit View Info.
  • In the dialog, change the name of the view as required, optionally add a description, and then select Done.
  • In the Action bar, select Done.

Move a runtime business view to a folder

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given view, do one of the following:

    • Select More Options (⋮ vertical ellipsis), select Move To Folder, and then select the folder you want to move the view to.
    • Expand the folder you want to move the view to, and then drag and drop the view to this folder.
  • In the Action bar, select Done.

Move a runtime business view out of a folder

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given view that exists in a folder, do one of the following:

    • Select More Options (⋮ vertical ellipsis), and then select Move Out of Folder.
    • Drag and drop the view out of the folder to the root list or to another expanded folder.
  • In the Action bar, select Done.

Remove all columns from a runtime business view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given view, select More Options (⋮ vertical ellipsis).
  • Select Clear All.
  • In the dialog, select Remove.
  • In the Action bar, select Done.

Remove a column from a business schema view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, expand a given business schema view.
  • For a given column or formula column in the business schema view, hover over the row, and then select Delete (trash can icon).
  • In the Action bar, select Done.

View details and sample data for a column in a business schema view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, expand a given business schema view.
  • For a given column in the business schema view, hover over the row, and then select View Details (eye icon).
  • Review the column details and sample data.

Set the base table for a business schema view

You can use the Business Schema Designer to set the base table for a business schema view only. This will enable a default query path for attribute-only queries, where one of the attributes is from the current business schema view.

Here are the steps to set the base table for a business schema view:

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given business schema view, select More Options (⋮ vertical ellipsis).
  • Select Set Base Table.
  • In the Set Base Table dialog, in Schema, select the physical schema that contains the table that you want.
  • In Base Table, select the base table that you want.
  • Select Set.
  • In the Action bar, select Done.
Note

To set the base table for an Incorta View, in the Analyzer, for the measure you want, drag a column from the Base Table to the Measures tray → pill properties panel → AdvancedBase Field.

Recommendation

In the case of using a base table other than a physical schema table, load the object data after defining the base table for the business schema view.

Change the base table for a business schema view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given business schema view that has a base table, select More Options (⋮ vertical ellipsis).
  • Select Change Base Table.
  • In the Change Base Table dialog, in Schema, select the physical schema that contains the table that you want.
  • In Base Table, select the base table that you want.
  • Select Change.
  • In the Action bar, select Done.

Remove the base table for a business schema view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given business schema view that has a base table, select More Options (⋮ vertical ellipsis).
  • Select Remove Base Table.
  • In the dialog, select Remove Anyways.
  • In the Action bar, select Done.

Delete a runtime business view

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given view, select More Options (⋮ vertical ellipsis).
  • Select Delete.
  • In the dialog, select Delete.
  • In the Action bar, select Done.

Business Schema Designer actions for folders

With the Business Schema Designer, you can perform the following actions for folders:

Important

Validation Rules for a folder name

A folder name…

  • Must be unique at the business schema level: no 2 folders or more can share the same name; however a view and a folder can share the same name in the business schema
  • Must be at least 1 character in length
  • Must begin with an alpha character, lower or upper case
  • After the first alpha character, can contain zero or more alphanumeric characters in lower, upper, or mixed case
  • After the first alpha character, can contain zero or more underscore (_) or Dollar sign ($) characters
  • Besides underscore (_) and Dollar sign ($), cannot contain special characters, symbols, or spaces

Create a new folder

  • In the Action bar, select +NewAdd New Folder.
  • In the Canvas, change the name of the new folder, as required. The default name is NewFolder#, where the # is an incremental number.
  • Make any required changes, and then in the Action bar, select Done.

Edit a folder

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, expand the folder, and make the necessary changes, for example,

    • To add a new view, in the Title bar, select +.
    • To order views in the folder, drag and drop the view to the place you want
    • To move a view to the folder, drag and drop the view to the folder
    • To move a view from the folder, drag and drop the view out of the folder
  • In the Action bar, select Done.

Create a runtime business view in a folder

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, expand the folder that you want to create a view in.
  • In the folder Title bar, select +.
  • Do one of the following:

    • Drag and drop columns from the Data panel to the new view to create a business schema view.
    • Select Create in Analyzer to create a new Incorta View. For more information, please review Tools → Analyzer.
  • In the Action bar, select Done.

Rename a folder

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given folder, select the folder name, and edit it as necessary.
  • Select any other place in the Business Schema Designer.
  • In the Action bar, select Done.

Empty a folder

When you empty a given folder, all its runtime business views are moved to the Business Schema root list.

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given folder, select More Options (⋮ vertical ellipsis).
  • Select Empty.
  • In the Action bar, select Done.

Delete a folder

When you delete a folder, all runtime business views in this folder are deleted as well.

  • In the Business Schema Designer, for a given folder or view, select More Options (⋮ vertical ellipsis).
  • Select Edit.
  • In the Canvas, for a given folder, select More Options (⋮ vertical ellipsis).
  • Select Delete.
  • In the dialog, select Delete.
  • In the Action bar, select Done.

© Incorta, Inc. All Rights Reserved.